Kako ukloniti pogrešan PPA repozitorij na Debian Linux 11

Nedavno sam pokušao instalirati ClipGrab, veoma moćan i jednostavan program za preuzimanje video klipova sa platformi kao što je YouTube i Dailymotion. Instalaciju sam pokušao izvesti preko PPA, te je tokom procesa došlo do greške jer je PPA koji sam ja dodao, pripadao Ubuntu Linux-u. Stoga se ClipGrab nije mogao instalirati pa je došlo do PPA greške. U ovom članku, pogledajte kako otkloniti PPA grešku u Debian Linux 11?

 Prije svega: šta je to repozitorij?

U Linux distribucijama, aplikacije nisu kao kod Windows-a, u .exe formatu gdje ih vi preuzmete i instalirate na vaše računalo. Ovdje se aplikacije nalaze u repozitorijima. Jednostavnim jezikom, repozitorij (PPA) je ništa više do kontenjer koji sadrži samu aplikaciju, njene biblioteke o kojima ista ovisi, njen izvorni kod, te potrebna ažuriranja za stabilan rad same aplikacije i novije verzije koje se pojave. Iz tih repozitorija se aplikacije dobavljaju/instaliraju, uklanjaju itd.

Kako izgleda PPA greška u terminalu?

E: The repository 'http://ppa.launchpad.net/xtradeb/apps/ubuntu kinetic Release' does not have a Release file. N: Updating from such a repository can't be done securely, and is therefore disabled by default. N: See apt-secure(8) manpage for repository creation and user configuration details.

Ova greška sprječava izvršavanje instalacija drugih aplikacija iz PPA repozitorija, ažuriranja, instalaciju nadogradnji itd, pa se ista mora ukloniti jer ovaj PPA pripada Ubuntu Linux distribuciji, a ne Debian-u.

Kako ukloniti ppa:xtradeb/apps?

Uklanjanje defektivnog/neispravnog PPA repozitorija je veoma jednostavan proces. Sve što je potrebno uraditi, je unjeti sljedeću komandu u terminal sa sudo privilegijama.

sudo add-apt-repository --remove ppa:xtradeb/apps

Nakon što se ova komanda izvrši, terminal će ukloniti gornji repozitorij. Nakon što se ova komanda izvrši, terminal će ukloniti gornji repozitorij. Da bismo potvrdili da je repozitorij uklonjen, potrebno je izvesti ažuriranja PPA repozitorija unosom sljedeće komande.

sudo apt update

Jednom pošto izvedete ažuriranja repozitorija, greška koju je uzrokovao pogrešan PPA je uspješno uklonjena, te je ponovo moguće izvesti instalacije aplikacija, ažuriranja i nadogradnji Debian Linux 11 distribucije. Do čitanja!!!

Share:

Nema komentara:

Objavi komentar

POPULARNI POSTOVI

Oznake

NAJNOVIJE